lotus



previous page: B09) Why does my guienvsystemenv program stop at startup?
  
page up: BETA Programming Language FAQ
  
next page: M02) What is MPW. Where do I get it?

M01) What are the system requirements to run BETA on Macintosh?




Description

This article is from the FAQ, by with numerous contributions by others.

M01) What are the system requirements to run BETA on Macintosh?

Release 3.1: BETA for Motorola Mac

* CPU: MC68020 processor or later (Release r3.1 works on PowerPC, please
look at question M04)
* RAM: 5 Mb memory (8 or 16 Mb is recommended)
* Disk: 16 Mb of free space on harddisk
* OS: System 7.x or later (or Multifinder under System 6.x)
* The MPW environment version 3.2 or later (please see question M02 for
details).
* An FPU to be able to use reals, please see question M03 for more
details.

That is, Release 3.1 runs on machines like Classic II, SE/30, LC, LC II, LC
III, Centris, and all Macintosh II, Quadra and PowerBook models (except
PowerBook 100). Release 3.1 cannot be used at Mac Plus, SE, and Classic.
Release 3.1 works on PowerPC, please look at question M04.

Release 4.0.2 or later: BETA for PowerMac

* CPU: PowerPC 601 processor or later
* RAM: 40 Mb memory
* Disk: 60 Mb of free space on harddisk
* OS: System 7.x or later
* The MPW environment, version 3.4.1 or later (please see question M02
for details), including
o MPW Shell
o Interfaces&Libraries
o PPCLink version 1.4 or later; or MWLinkPPC from Metrowerks, see
M02
o Rez
These can be obtained from Apple from the Essentials-Tools-Objects
(ETO) volume 20 or later.
* FPU to be able to use reals (please see question M03 for more details).
However, a hardware FPU is build into most PowerPC Macintosh.

That is, Release 4.0.2 should work for alle PowerMac models. Please note
that, Release 4.0.2 or later does not work on motorola macintoshes.

 

Continue to:















TOP
previous page: B09) Why does my guienvsystemenv program stop at startup?
  
page up: BETA Programming Language FAQ
  
next page: M02) What is MPW. Where do I get it?